Modify

Opened 14 years ago

Closed 14 years ago

Last modified 10 years ago

#3 closed enhancement (invalid)

0.10.3 broken against head of trac-monotone

Reported by: ssamuel@… Owned by: Thomas Moschny
Priority: major Component: tracmtn
Version: 0.0.7 Keywords: <Key>
Cc:

Description

Running trac 0.10.3 against the head of trac monotone available on venge.net (is this the right place to get it?) Immediately get the following error when clicking on browse source:

Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch

resp = chosen_handler.process_request(req)

File "/usr/lib/python2.4/site-packages/trac/versioncontrol/web_ui/browser.py", line 100, in process_request

rev_or_latest = rev or repos.youngest_rev

File "/usr/lib/python2.4/site-packages/trac/versioncontrol/api.py", line 189, in <lambda>

youngest_rev = property(lambda x: x.get_youngest_rev())

File "/usr/lib/python2.4/site-packages/TracMonotone-0.0.2-py2.4.egg/tracvc/mtn/backend.py", line 170, in get_youngest_rev

return leaves[dates[-1]]

IndexError: list index out of range

Attachments (0)

Change History (5)

comment:1 by Thomas Moschny, 14 years ago

Priority: blockermajor

This is most likely a configuration problem. If your webserver uses multiple processes to serve your trac instance, you must use the bsddb3 caching backend. The dbmshelve backend cannot be used in multi-process environment.

in reply to:  1 comment:2 by ssamuel@…, 14 years ago

Replying to moschny: I'm running tracd, so I don't think this applies (only one process). I tried adding the dbmshelve backend as suggested, but still got the same error.

comment:3 by anonymous, 14 years ago

Cc: ssamuel@… added

comment:4 by Thomas Moschny, 14 years ago

Please try the latest version from venge.net (sorry, no downloads here yet) and flush (i.e. remove) the cache before running it. Also, make sure that tracd can write to the cache dir.

Did you properly set the path to the monotone binary in your trac.conf? The path must be absolute.

And, does your database to be served contain revisions at all? I think TracMtn misbehaves in the case of an empty database.

The error message you gave indicates that the output of 'mtn -d your.db automate leaves' was empty (and this output is not cached), so maybe you should try that command by hand.

comment:5 by ssamuel@…, 14 years ago

Resolution: invalid
Status: newclosed

After upgrading to 0.32 everything looks good. Marking as invalid. Thanks for your help.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Thomas Moschny.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.